C# SAP Connector .NET Framework 4.5 版本下载

公司对接 SAP 数据使用 SAP Connector 程序,主要是两个类库:sapnco.dll、sapnco_utils.dll

但是没想到它的版本如此混乱,.NET 2.0 和 .NET 4.0 也不兼容,使用中经常会出现找不到 sapnco.dll 的错误。

而且还有一个不容易注意到的坑:

.NET 2.0 版本依赖 Microsoft C++ Runtime DLLs version 8.0,也就是要安装 Microsoft Visual C++ 2005 SP1 Redistributables。

.NET 4.0 版本依赖 Microsoft C++ Runtime DLLs version 10.0,也就是要安装 Microsoft Visual C++ 2010 Redistributables。

官方说明文档:

https://support.sap.com/en/product/connectors/msnet.html

最新版本的 .NET 3.0.24 没找到(需要登录才能下载,个人注册登录依然没有下载权限)。

不过找到了 3.0.22 的版本,凑合够用了,等找到新版本再来更新。

NCo 3.0下载地址:

https://1drv.ms/u/s!Ai7Vwjjjlr_ZhfRk2WlQmQ7PxWDlpg?e=f9C27Y

VC++ 库下载地址:(选择合适的版本)

https://1drv.ms/u/s!Ai7Vwjjjlr_Zha4C1A9l7JKhuMQJww?e=HHjTpV

发表评论

您的电子邮箱地址不会被公开。